CallCorp - New Incident - CallCorp Contact Center US (BND3) – Incident details

All systems operational

Service Status
To subscribe to this status page, please Contact Support
Or use our API to pull updates to a page of your own

New Incident - CallCorp Contact Center US (BND3)

Resolved
Partial outage
Started 4 days agoLasted about 2 hours

Affected

CallCorp Contact Center US

Partial outage from 12:07 PM to 2:20 PM

CallCorp Contact Center US (BND3)

Partial outage from 12:07 PM to 2:20 PM

Updates
  • Resolved
    Resolved

    Our engineering teams have RESOLVED the technical issue which may have been impacting your service.

    Users may need to log out of the platform, clear their browser cache, and log back in.

    No further updates are expected.

  • Monitoring
    Monitoring

    Our engineers have implemented a fix and are currently monitoring the result.

  • Investigating
    Investigating

    We are aware of a technical issue which may impact your service on US (BND3) .

    Some outbound calls may be intermittently failing to connect.

    Engineering teams are investigating

    We will provide updates shortly.