CallCorp - Reporting Data Issue – Incident details

All systems operational

Service Status
To subscribe to this status page, please Contact Support
Or use our API to pull updates to a page of your own

Reporting Data Issue

Resolved
Degraded performance
Started 29 days agoLasted 3 days

Affected

CallCorp Contact Center US

Degraded performance from 9:29 PM to 3:19 PM

CallCorp Contact Center US (BND2)

Degraded performance from 9:29 PM to 3:19 PM

CallCorp Contact Center US (BND3)

Degraded performance from 9:29 PM to 3:19 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Update
    Update

    We have remediated a significant portion of the degraded data set. Our team is currently focused on isolating and resolving the remaining data inconsistencies. We project that the full data recovery and validation process will be completed within the next few hours. Further updates will be provided should this timeline change.

  • Identified
    Identified

    We are having a data issue affecting reporting. We are actively working on a resolution.