CallCorp - Incident - CallCorp Contact Center US (BND2) – Incident details

All systems operational

Service Status
To subscribe to this status page, please Contact Support
Or use our API to pull updates to a page of your own

Incident - CallCorp Contact Center US (BND2)

Resolved
Major outage
Started 27 days agoLasted about 3 hours

Affected

CallCorp Contact Center US

Major outage from 9:20 PM to 12:30 AM

CallCorp Contact Center US (BND2)

Major outage from 9:20 PM to 12:30 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We are aware of a technical issue which may impact your service on US (BND2) .

    At this time, users may have issues logging in and calls may be failing

    Engineering teams are investigating

    We will provide updates shortly.